500 Errore interno del server

Skip to main content
Du bist hier:
Drucken

500 Errore interno del server

500 Errore interno del server

 

Ricevi il messaggio di errore 500 interno Server Error sul tuo sito web con PHP. Ti mostriamo come andare a fondo dell’errore.

  1. Accedi all’amministrazione di hosting
  2. Aprire le impostazioni PHP
  3. Modificare il valore “Display Errors” in “ON”.
  4. Attendere 2 minuti e ricaricare la pagina
  5. Verrà visualizzato il codice PHP che causa l’errore.
  6. Per motivi di sicurezza, ricordarsi di riportare gli errori del display su ‘OFF’.

 

Causa frequente: versione PHP errata

Una causa molto frequente dell’errore 500 Internal Server Error è una versione PHP che non corrisponde al CMS utilizzato (ad esempio WordPress, Drupal, Joomla) o a singoli plugin. Questo accade tipicamente dopo un aggiornamento automatico di PHP sul server o dopo un aggiornamento del CMS.

  1. Apri le impostazioni PHP del dominio nell’amministrazione di hosting.
  2. Controlla quale versione PHP è attualmente impostata.
  3. Prova a passare a un’altra versione PHP: per i sistemi più vecchi solitamente una versione precedente (ad esempio PHP 7.4 invece di 8.x), per i sistemi più recenti eventualmente una versione più recente.
  4. Ricarica quindi il sito web e verifica se l’errore è scomparso.

Se non riesci a trovare da solo la versione PHP corretta, contatta il nostro supporto – saremo felici di aiutarti.

Related Post